OM606 Revisited for Defender

brycee22

Member
I like your progress Arcadeus. Curiously, I just found this thread while Googling something else as I am also installing a 606 into my 110 and it appears we're about similar progress. I'm hoping to get it fired up for the first time within the next couple weeks. Just need to complete some wiring and tubing.

We took similar approaches but I opted for the 7.5mm mechanical IP from deiselmeken. I also had Ashcroft build me an HD R380 Stumpy and HD rebuilt LT230 for good measure. Most everything else is sourced from K2 (love working with Dominic and Duncan...great guys) and also from DPUK (I don't care that for that Luke guy, but so far the parts supplied have seemed good quality).

When the borders open up we'll have to meet up somewhere and compare notes. I'm just down here in Seattle. Attached are some random photos of the build.
 

Attachments

  • 110_om606.jpg
    110_om606.jpg
    534.2 KB · Views: 300
  • 19.jpg
    19.jpg
    735.8 KB · Views: 315
  • 31.jpg
    31.jpg
    91.6 KB · Views: 286
  • 76.jpg
    76.jpg
    202.7 KB · Views: 296
  • IMG_2464.jpg
    IMG_2464.jpg
    102.4 KB · Views: 273
  • image32.jpeg
    image32.jpeg
    68.8 KB · Views: 284

Arcadeus

Well-known member
Nice! Will have to check that out when we can. I have the same pump ( not sure if yours is EDC) and my transfercase is also from Ashcroft. What turbo are you using?

Btw here are some pics of the progress... It's almost rolling, just having an issue with the map sensor
 

Attachments

  • 0F14613F-164A-46D4-82BE-7EC58F3ADB4D.jpeg
    0F14613F-164A-46D4-82BE-7EC58F3ADB4D.jpeg
    185.9 KB · Views: 219
  • CA0EA1E8-6049-4B6D-AFF8-4F69D035B0A9.jpeg
    CA0EA1E8-6049-4B6D-AFF8-4F69D035B0A9.jpeg
    202 KB · Views: 226
  • 99508338-DAD9-4A7B-A6D4-3481F959412E.jpeg
    99508338-DAD9-4A7B-A6D4-3481F959412E.jpeg
    160.5 KB · Views: 219
  • 599B8093-3891-4E59-BDBC-CF0FF975C7F9.jpeg
    599B8093-3891-4E59-BDBC-CF0FF975C7F9.jpeg
    195 KB · Views: 224
  • 5F66786E-50D4-4210-9F23-35E6F341407C.jpeg
    5F66786E-50D4-4210-9F23-35E6F341407C.jpeg
    77.8 KB · Views: 216

brycee22

Member
Very nice. Why the far reach with the air intake hose? I'm currently debating how I want to do mine. My 110 is a RHD and I have a snorkel on the opposite (passenger) side. I would still like to utilize a snorkel but I'd have to source one for the drivers side and I'm concerned that a snorkel might be too constricting. Currently I don't have a solution for tapping into the side vent, but I figure once everything is installed, I (and by "I", I mean my mechanic) can make something custom real quick.

As for a turbo, for now I'm just using the Hybrid V2 turbo sourced from DPUK. I wanted to be a bit conservative with the initial build, but use HD components if I wanted to upgrade later. I figure upgrading the turbo later would be easy.

Have you had any clearance issues so far? And where did you get that guard pan just under the muffler there? Are you keeping stock prop shafts?

I also decided last minute to convert from a 2.5td engine mount to a 300tdi mount which required a bit of fab work. Turned out good though. I also have the HD half shafts and drive flanges (Ashcroft) yet to be installed, but need to swap out the front diff gear to accommodate for the different spline count first.
 

Attachments

  • 115.jpg
    115.jpg
    89.3 KB · Views: 224
  • Image.JPEG
    Image.JPEG
    219.3 KB · Views: 267
  • IMG_2477.jpg
    IMG_2477.jpg
    92.1 KB · Views: 237
  • IMG_1091.jpg
    IMG_1091.jpg
    184.6 KB · Views: 229
  • IMG_1103.jpg
    IMG_1103.jpg
    219.6 KB · Views: 245
  • IMG_1116.jpg
    IMG_1116.jpg
    261.5 KB · Views: 230

brycee22

Member
So I assume you just hacked the original radiator mount off? Just did a test placement last weekend thinking this just uses the original mounts, but when placed, the radiator is way too high....(pics below). Before we go hacking away, was this your approach as well?
 

Attachments

  • IMG_1647.jpg
    IMG_1647.jpg
    216.5 KB · Views: 197
  • IMG_1648.jpg
    IMG_1648.jpg
    184.7 KB · Views: 196

Arcadeus

Well-known member
So I assume you just hacked the original radiator mount off? Just did a test placement last weekend thinking this just uses the original mounts, but when placed, the radiator is way too high....(pics below). Before we go hacking away, was this your approach as well?
Yes the original mounts were replaced.. i think they moved it forward a bit too... do you have the AC grill mount?
 

Arcadeus

Well-known member
So she is up and running now. Turned out the transmission issue was a single option in how the TCU communicates over its CAN bus line. As soon as I switched it to PCL it worked fine. Also I have the ECU and TCU communicating on the same CANbus line now i.e. obdll link will work
 

Arcadeus

Well-known member
I do recommend however that you use an external fuel pump and blank the lift pump off on the IP.

So I am currently installing a dakota digital gauge system. I went for separate gauges instead of the one unit.

HDX-2070: Universal 7 Gauge Round, Analog  HDX Instruments



The original panel wont fit all of them so I got these from raptor engineering and they custom designed the panel to fit the three larger gauges.

Standard-Binnacle.jpg



for the smaller cluster I also bought one of these....
1632183355852.png


Not sure if I like the look but if it bugs me enough i will eventually do something about it and it will be functional for now.
 

Arcadeus

Well-known member
The reason I went with the display center in the middle gauge is because I can program it to display my egt and boost. or alternatively, I could just get it to flash a warning once the readings hit a programmable threshold.
 

brycee22

Member
I do recommend however that you use an external fuel pump and blank the lift pump off on the IP.

Why do you recommend using an external fuel pump? Also, how did you work out your air hoses for the turbo and inlet manifold? Got any pics to share? I'm currently trying to figure out how I want to go about it. I tried K2, but they sent me a bunch of stuff that didnt work too well.
 

Arcadeus

Well-known member
Why do you recommend using an external fuel pump? Also, how did you work out your air hoses for the turbo and inlet manifold? Got any pics to share? I'm currently trying to figure out how I want to go about it. I tried K2, but they sent me a bunch of stuff that didnt work too well.
 

Attachments

  • C4C43B80-4B0D-457F-896C-19802192C106.jpeg
    C4C43B80-4B0D-457F-896C-19802192C106.jpeg
    218.6 KB · Views: 234
  • 9D418FB1-63FC-451F-A665-03137C8419F8.jpeg
    9D418FB1-63FC-451F-A665-03137C8419F8.jpeg
    220.1 KB · Views: 234
  • 156F67EA-FAE6-4F82-BF14-FF2E8CC19E53.jpeg
    156F67EA-FAE6-4F82-BF14-FF2E8CC19E53.jpeg
    210.3 KB · Views: 241

Napalm00

Technical Excellence Contributor
Fyi a good buddy just got his om606 up and going. He has some pretty serious surging issues. Dpuk makes a kit to help , must go on the pump body fyi
 

Arcadeus

Well-known member
Fyi a good buddy just got his om606 up and going. He has some pretty serious surging issues. Dpuk makes a kit to help , must go on the pump body fyi
That kit is there because dpuk doesn't tune their pumps properly... What pump is he using?
 

Arcadeus

Well-known member
I’m not 100 percent sure that the snorkel isn’t going to starve it for air… I did the calculations and if I recall correctly it’s good up to 4500 rpm or so…
 

MountainD

Technical Excellence Contributor
I’m not 100 percent sure that the snorkel isn’t going to starve it for air…
i had to read this 10 times to understand what you’re saying, and now I’m 100% uncertain that what you said isn’t entirely incorrect. 🤪
awesome build—can’t wait to hear it run!,
 

Arcadeus

Well-known member
i had to read this 10 times to understand what you’re saying, and now I’m 100% uncertain that what you said isn’t entirely incorrect. 🤪
awesome build—can’t wait to hear it run!,
And in English… I don’t know if the air intake is large enough to supply the air the turbo wants at higher rpm.
 
Top