NAS-ROW - The Land Rover Defender Forum  

Go Back   NAS-ROW - The Land Rover Defender Forum > NAS-ROW Classified Forums > Parts for Sale

Reply
 
Thread Tools Display Modes
Old 12-04-2018, 10:32 AM   #11
NPT90
Senior Member
 
NPT90's Avatar
 
Join Date: Jan 2017
Location: MD
Posts: 329
Thanks: 18
Thanked 27 Times in 25 Posts
Default

It sounds like your live ignition feed is not staying live for long. I would put a meter on it and turn the ignition on to ensure it is running the relay
NPT90 is offline   Reply With Quote
Old 12-04-2018, 11:48 AM   #12
RDavisinVA
Senior Member
 
RDavisinVA's Avatar
 
Join Date: Nov 2016
Location: VA USA
Posts: 640
Thanks: 44
Thanked 136 Times in 97 Posts
Default

Thanks for adding some value to the problem solving.
__________________
RDavisinVA
RDavisinVA is online now   Reply With Quote
Old 12-04-2018, 12:29 PM   #13
NPT90
Senior Member
 
NPT90's Avatar
 
Join Date: Jan 2017
Location: MD
Posts: 329
Thanks: 18
Thanked 27 Times in 25 Posts
Default

I always do
NPT90 is offline   Reply With Quote
The Following User Says Thank You to NPT90 For This Useful Post:
RDavisinVA (12-06-2018)
Old 12-04-2018, 12:36 PM   #14
NPT90
Senior Member
 
NPT90's Avatar
 
Join Date: Jan 2017
Location: MD
Posts: 329
Thanks: 18
Thanked 27 Times in 25 Posts
Default

It appears that ECM also controls the glow plug relay via a coolant temperature sensor you may not have restored

Just another possibility if you are using a TD5 loom on your 200TDI
NPT90 is offline   Reply With Quote
Old 12-04-2018, 04:09 PM   #15
Tomaco1
Member
 
Join Date: Feb 2017
Location: L.I. NY
Posts: 68
Thanks: 2
Thanked 6 Times in 6 Posts
Member Trucks
Default

Everything works as it should
Except the warning light

Glow plugs light for 10-15 seconds
L spade shows power, comes on with the switch but never turns off
Glow plug light flickers once and stops
until I put the test light on it
Test light lights, but so does the dash light
Ground seems solid
Tomaco1 is offline   Reply With Quote
Old 12-05-2018, 09:16 AM   #16
NPT90
Senior Member
 
NPT90's Avatar
 
Join Date: Jan 2017
Location: MD
Posts: 329
Thanks: 18
Thanked 27 Times in 25 Posts
Default

Are you using the TD5 loom?
NPT90 is offline   Reply With Quote
Old 12-05-2018, 09:26 AM   #17
NPT90
Senior Member
 
NPT90's Avatar
 
Join Date: Jan 2017
Location: MD
Posts: 329
Thanks: 18
Thanked 27 Times in 25 Posts
Default

Quote:
Originally Posted by Tomaco1 View Post
Everything works as it should
Except the warning light

Glow plugs light for 10-15 seconds
L spade shows power, comes on with the switch but never turns off
Glow plug light flickers once and stops
until I put the test light on it
Test light lights, but so does the dash light
Ground seems solid
Don't count out the possibility that the relay is bad out of the box... wouldn't be the first time something like that happened.
NPT90 is offline   Reply With Quote
Old 12-05-2018, 10:33 AM   #18
Tomaco1
Member
 
Join Date: Feb 2017
Location: L.I. NY
Posts: 68
Thanks: 2
Thanked 6 Times in 6 Posts
Member Trucks
Default

Quote:
Originally Posted by NPT90 View Post
Don't count out the possibility that the relay is bad out of the box... wouldn't be the first time something like that happened.
thats what im starting to think
Tomaco1 is offline   Reply With Quote
Old 12-05-2018, 03:17 PM   #19
RDavisinVA
Senior Member
 
RDavisinVA's Avatar
 
Join Date: Nov 2016
Location: VA USA
Posts: 640
Thanks: 44
Thanked 136 Times in 97 Posts
Default

I would agree the relay is bad if it were hooked up exactly as the legend in post 1 describes, but this has yet to be confirmed.
__________________
RDavisinVA
RDavisinVA is online now   Reply With Quote
Old 12-05-2018, 07:09 PM   #20
Tomaco1
Member
 
Join Date: Feb 2017
Location: L.I. NY
Posts: 68
Thanks: 2
Thanked 6 Times in 6 Posts
Member Trucks
Default

It’s all good. Relay works as it should.

My issue is with the TD5 warning light I tied into at the dash. For some reason it is sending power out?
Tomaco1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

» Log in
User Name Not a member yet?
Register Now!
Password
» Today's Birthdays
None
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:35 AM.


Powered by vBulletin® Version 3.8.10 Release Candidate 2
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.