What's Missing Here?

GynormousMellon

Well-known member
Looks like the PO wrapped the end of the trans stick in electrical tape then wedged the shift knob onto it. What should be here to hold the shift knob in place? IMG_20180608_170932.jpegIMG_20180608_170921.jpeg

Sent from my Pixel XL using Tapatalk
 

85RED110

Well-known member
Mine is installed in the EXACT same manner. Don't know how it got that way, or how it's supposed to be, but I haven't placed this fix very high on my to-do list.... yet. So many other things to do.

Sent from my SM-G930V using Tapatalk
 

DefendersNW

Well-known member
Rubber tube - comes with the shift-knobs

If you can find some hose that is the same outer diameter as the knob, and slightly smaller ID than the threaded shaft a ~3/4" piece will work in the same manner as the original.
 

SARTech

Well-known member
Mine is the same way. It slowly rotates counter clockwise, take about 215 miles to get a full 90 deg to the left.
 

elbee

Well-known member
Mine is installed in the EXACT same manner. Don't know how it got that way, or how it's supposed to be, but I haven't placed this fix very high on my to-do list.... yet. So many other things to do.

Sent from my SM-G930V using Tapatalk
Mine is installed in the exact same manner as well!
 
Had the same issue with the hi/low knob on the RRC. Couldn?t find the part (to be honest I didn?t look too hard) so I machined a plug from 1/2? hdpe and threaded the center. Thought I?d have to glue it in but the fit was tight and it?s not coming off.


Sent from my iPhone using Tapatalk
 
Top